summaryrefslogtreecommitdiff
path: root/sci-electronics/kicad/files/kicad-9.0.6-fix-cmake4-compat.patch
blob: ab06a00219b6f878be77999ced00c742a1ba8d5e (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
https://bugs.gentoo.org/970924

CMake >= 4.0 has removed compatibility with cmake_minimum_required
versions less than 3.5. Bump the minimum versions in vendored
thirdparty code to fix the build.

--- a/thirdparty/sentry-native/external/crashpad/third_party/zlib/zlib/CMakeLists.txt
+++ b/thirdparty/sentry-native/external/crashpad/third_party/zlib/zlib/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.0)
+cmake_minimum_required(VERSION 3.5)
 set(CMAKE_ALLOW_LOOSE_LOOP_CONSTRUCTS ON)

 project(zlib C)
--- a/thirdparty/pybind11/tests/test_cmake_build/subdirectory_target/CMakeLists.txt
+++ b/thirdparty/pybind11/tests/test_cmake_build/subdirectory_target/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required(VERSION 3.4)
+cmake_minimum_required(VERSION 3.5)

 # The `cmake_minimum_required(VERSION 3.4...3.18)` syntax does not work with
 # some versions of VS that have a patched CMake 3.11. This forces us to emulate